Multiple-Choice Plugin Fail

We had purchased the multiple-choice plugin but are running into problems where it isn’t working. Multiple choice questions in our backup exports (but also new questions I create while troubleshooting) are unresponsive when selected as a player. The settings for the questions appear correct from the admin > challenges view. But when the icon is clicked, nothing at all happens.

The same backup export file imported into the hosted CTF worked fine (the multiple choice questions worked). So I’m guessing perhaps an incompatibility with the file we have and the v3.5.1 we are using for self-hosted?

Or perhaps the zip got corrupt? Is it possible to have the file resupplied to us?


Perhaps related, I get the below error in the web console when ‘clicking’ the multiple-choice questions.

The best I can recommend without more information is downloading the latest copy of the plugin. See Store Purchases | CTFd Docs.

If that doesn’t work reach out to [email protected].

Will try this first. Checking with co-worker who purchased the plugin; if they have no link, we’ll reach out to support, or simply purchase again (hope that solves it).

I’ve found our download link and redownload, and placed the file on our S3 bucket from where our automation retrieves it.

Is there some additional step I’ve overlooked? We perform the following in our AWS EC2 user_data script. All works, EXCEPT the multiple choice questions are unresponsive when they are clicked on. In the editor, they appear correct.

echo "******** FETCH S3 OBJECTS ********"
aws s3api get-object --bucket ctf-objects --key ./
echo "******** UNZIP PLUGIN ********"
unzip ./ -d /CTFd/CTFd/plugins/
echo "******** FETCH THEME ********"
cd /CTFd/CTFd/themes
git clone
echo "******** START CTF ********"
cd CTFd
docker-compose up -d
sleep 30
echo "******** IMPORT CTF BUILD ********"
docker exec ctfd_ctfd_1 /bin/bash -c "python3 import_ctf ./CTFd/"
echo "******** SET CTF THEME ********"
docker exec ctfd_ctfd_1 /bin/bash -c "python3 set_config ctf_theme core-beta"

Following up on this again… Any suggests? Even if I reset the instance and create a single multiple choice question, the question appears but clicking on it results in nothing.

Resolved. The issue was determined to be within the ‘multiple-choice’ plugin. Supported provided a not yet released version of the plug-in that works with the ‘core-beta’ theme and hinted that soon the core-beta theme functionality (with some minor updates?) would get merged into ‘core’ theme and solve this problem.